Update 'preflight.sh' (#899)

As per title to support Go 1.18

Co-authored-by: Phil S <ullarah@noreply@mills.io>
Reviewed-on: #899
Reviewed-by: James Mills <james@mills.io>
Co-authored-by: Phil S. <ullarah@noreply@mills.io>
Co-committed-by: Phil S. <ullarah@noreply@mills.io>
pull/901/head^2
Phil S. 9 months ago committed by James Mills
parent e90df1504f
commit 363329310c
  1. 4
      preflight.sh

@ -75,8 +75,8 @@ check_goversion() {
gover="$(go version | grep -o -E 'go[0-9]+\.[0-9]+(\.[0-9]+)?')"
if ! go version | grep -E 'go1\.17(\.[0-9]+)?' > /dev/null; then
log2 "Go 1.17 is required, found ${gover}"
if ! go version | grep -E 'go1\.1[678](\.[0-9]+)?' > /dev/null; then
log2 "Go 1.16+ is required, found ${gover}"
return 1
fi

Loading…
Cancel
Save